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1.1 Hardware Controls: 
System Preferences



1.1.1 Creating User 
Accounts



Start up the Mac notebook and log in as Admin. Choose System Preferences… from the Apple Menu.



Click Users & Groups.



Click the padlock.



Enter the administrator username and password (admin and admin) and click Unlock.



Click the + button.



Enter your details. This temporary account will be deleted at the end of the class. Click Create User.



Click Login Options.



Click the Automatic login: popup menu and choose your own name.



Enter your password when prompted. Click OK.



Now your Mac will automatically log on to your account when it’s started.



Choose Log Out from the Apple menu.



Log in into your newly created account.



1.1.2 Energy Saver



Choose System Preferences from the Apple menu.



Click on Energy Saver.



Click the padlock.



Enter the administrator’s username and password when prompted and click Unlock.



Here are the default settings when you’re connected to the power adapter. You can change them if you wish.



Here are the default settings when you’re running on battery. You can change them if you wish. Click Show All when you’re done.



1.1.3 Trackpad



Click Trackpad.



Click the Point & Click tab. Click Tap to click, Three finger drag and adjust the Tracking speed until you are comfortable.



Click the Scroll & Zoom tab.



Move the cursor over each section to see what each setting does.



Click the More Gestures tab.



Move your pointer over each section to see what each gesture does. Click Show All when done.



Click General.



Here you can see that scroll bars are shown automatically. You can change this setting if you wish. Click Show All.



1.1.4 Desktop and 
Screen Saver



Click Desktop & Screen Saver.



Change the Desktop Picture to any picture you like. Click the Screen Saver tab.



Chose a screen saver you like. Click Hot Corners.



Assign a desired behavior to every screen corner and click OK. For instance, you can choose to start the screen saver when the pointer is in the upper left 
corner. Click OK when done.



Click Show All.



1.1.5 Network



Click Network.



Choose the Network Name: Classroom Wireless and enter the password ‘password’ when prompted. Notice the indicator will turn green. If you have a 
problem click the Assist me… button.



Click Diagnostics. This will help to see what’s wrong with your network connection. There should be no problems at present. Click Show All when you’re 
done.



1.1.6 Printers



Click Printers & Scanners.



Use the administrator’s username and password to unlock it. Connect your printer. OS X will automatically recognise and install all the printers it detects.



If the printer incorporates a scanner, that will be installed as well. Click Show All.



1.1.7 Keyboard 
shortcuts



Click Keyboard.



Click Shortcuts.



Keyboard shortcuts are displayed. Click Show All.



Click Language & Region.



Click +.



Choose a preferred language to add. Here I am adding Chinese (simplified). Click Add.



Click Use English.



Select Pinyin, Stroke and Trackpad Handwriting by Command-clicking them. Click Add 3 Input Sources.



Here you can see Chinese (Simplified) has been added.



Quit System Preferences when done.



Look at the top row of keys on the keyboard and identify the hardware control keys for brightness, volume control and power. 



1.2 The Mac Desktop



1.2.1 The Menu Bar



On the left side of the screen, you’ll see the Apple menu and the Application menu.



On the right of the screen you will see the Menu items.



You can use the Apple menu to Log off, Sleep and Shut Down your computer.



The Finder is similar to Windows Explorer. Explore the various menu commands under the Finder menu.



Explore the various menu commands under the File menu.



Explore the various menu commands under the Edit menu.



Explore the various menu commands under the View menu.



Explore the various menu commands under the Go menu.



Explore the various menu commands under the Window menu.



Explore the various menu commands under the Help menu.



Time Machine is used to back up the contents of the hard disk.



Bluetooth is used to connect with other Bluetooth devices such as mice, keyboards, earphones and mobile phones.



The Wi-Fi menu item allows you to join a wireless network.



The speaker item allows you to adjust the computer’s volume.



The battery icon shows how much power you have left.



The Language item allows you to switch to a different input method.



The clock shows the time, can be configured as an analog or digital clock, and can change the time and date.



The Fast user switching menu allows you to change users easily.



Spotlight allows you to find stuff on your Mac, fast.



Notifications will tell you when something important happens, like new email, new messages or available software updates.



1.2.2 Main Desktop 
Access Gestures



Let’s explore the main Desktop Access Gestures. Click on the Safari icon in the lower part of the screen.



Click the arrows on the top right corner of the window.



Safari will appear full screen. Swipe up with 4 fingers.



You will see your Desktop, and all currently running applications. At present only Safari is running. Swipe left and right with 4 fingers to switch between 
screens. Swipe down with 4 fingers when done.



Push your cursor to the top right and click the full screen arrows.



Safari is no longer full screen. Let’s open another window.



Choose File-> New Window.



A second window opens. Swipe down with 4 fingers.



You can see all the windows that Safari has open. 



Choose Quit Safari from the Safari menu.



To see all your applications, pinch with a thumb and 3 fingers. This will activate Launchpad. Unpinch with a thumb and 3 fingers to make it go away.



1.3 The Dock



1.3.1 Customising the 
Dock



The Dock is at the bottom of the screen. The left side has application shortcuts. The right side has shortcuts for everything else.



To add a new application shortcut to the Dock, choose Go -> Applications from the Go menu.



Here we have dragged ‘Chess’ into the dock. 



Choose Home from the Go menu to display your home directory.



Drag the Documents folder from your home directory to the right side of the Dock. Now you will have easy access to it.



Right-click the divider between the left and the right side.



Choose Turn Magnification On.



Dock items will become larger when the pointer passes over them.



1.3.2 Running and 
Quitting Apps



Click on Safari to launch it again.



Applications that are running have a blue light under their icon in the Dock.



Click on the Red button to close the open Safari window.



Note that Safari is still running.



To really quit Safari, choose Quit Safari from the Safari menu.



1.3.3 Managing 
Stacks and Trash



We’re going to explore Stacks. Let’s get some files to use. Choose Computer from the Go menu.



Double click on Macintosh HD.



Double click on Library.



Find the Desktop Pictures folder.



Drag it to the Desktop. A copy will appear on your Desktop.



Drag the Desktop Pictures folder to the Downloads folder in the Dock.



Click the Downloads folder and a list of its contents will appear.



Right click the Downloads folder. Choose Grid from the popup menu.



Now the items in the Downloads folder appear as a grid. The Open in Finder icon opens the folder in a new Finder window.



Click the Desktop Pictures Folder.



The contents appear. Note the back arrow which you can click to go back to the parent folder.



Drag a couple of pictures into the Trash can.



The picture of the Trash can changes to show that it has something inside it. Double click the Trash can.



If you have placed items into the trash by mistake, you can drag them out now.



Click Empty trash to remove the items permanently.



Click Empty Trash when you seen this warning.



1.4 The Finder 
Window



1.4.1 Finder toolbar



To get a new Finder window, click the smiling Mac OS icon.



The All My Files item is selected. Click the List view.



This is the List view. Click the Column view button.



This is the Column view. Click the Cover Flow view.



This is the Cover Flow view. Click the Fields button.



Choosing Fields allows you to display items in categories. Choose a field and note the change in the view.



Click list view. Click any file and press the space bar.



A preview of the image appears. This feature is called Quick Look.



1.4.2 Sidebar



On the left side of the Finder window is the sidebar.



Click AirDrop. AirDrop allows me to transfer files easily over the wireless network. Just drag the item to the other person’s name.



Applications displays the applications in the Applications folder.



Desktop contains the items which appear on your Desktop.



Documents is the equivalent of the Windows My Documents folder. It is the default location for applications to save documents.



Downloads is the repository of everything that you download from the internet.



Devices shows you any devices connected to your Mac.



Shared shows you any file servers that are on the same network as you are.



To see the effect of tags, click All My Files. Right click a picture in the Desktop Pictures folder.



Type ‘my own tag’ in the tags area and press Return.



The tag you entered appears in the sidebar. Clicking it displays all files with that specific tag.



1.4.3 Manipulating 
Windows



To resize a window, drag any corner or side.



Clicking the green button toggles between the optimum size of a window and the size you set.



Clicking the yellow button minimises the window into the Dock.



Clicking the minimised window expands it again.



Clicking the double headed arrow on the top right makes the window full screen.



Place your cursor on the top right corner of the full screen window and click the double headed arrow again to restore the window to its original state.



File -> New Tab Opens a new Finder Tab. To close a tab, move your cursor to the left side of the tab and a small x box will appear. Click the x to close the 
Tab.



1.4.4 Spotlight 
searching



You can use Spotlight to search. Press Command-Space to activate it.



Entering an equation into Spotlight will solve the equation.



Typing in words  and choosing Dictionary in the Spotlight menu will display their definition.



Typing in a search term will display everything that contains that search term.



1.5 File Operations



1.5.1 Creating 
Documents



Pinch with a thumb and 3 fingers to activate Launchpad. You can drag any application you like to a different screen.



You can search for a specific application by typing its name in the search field. Search for TextEdit. Click it.



TextEdit will automatically open a new file. If it does not, choose File ->  New. Type in a few words, and choose File -> Save. Give it a name, the tag ‘Red’ 
and save it in the Documents folder.



Choose Documents from the Go menu.



You will see the file you just saved. Note that you can also open a new Finder window and click Documents in the sidebar. Right click the file.



Choose Get Info.



Here’s the information about the file you saved.



1.5.2 Duplicating, 
Renaming and Moving 

Documents



Open the document you saved earlier if required. Click on the arrow next to the name of the open file.



Change the name to ‘my file 2’ and choose Desktop from the Where: menu.



The file is moved from the Documents folder to the Desktop.



Note that the file is no longer in the Documents folder.



Click once on the file on the Desktop to select it. Choose Duplicate from the File menu.



A copy of the original file appears with the file name highlighted. Change the name of the file to “my file 3” and press Return.



The duplicated file also appears on the Desktop. At this point you should have two files on the Desktop, my file 2 and my file 3.



1.5.3 Deleting 
Documents



Assume we don’t need “my file 3” any more. Put it into the Trash. Click the Trash to see its contents. Click Empty trash.



Click Empty Trash again when prompted.



1.5.4 Sharing 
Documents



With “my file 2” still selected, choose Duplicate from the File menu again.



Click the Red button. You will be prompted to save the file.



Enter the data as shown. 
Save As: My file word version. 
Tags: Blue 
Where: Desktop 
File Format: Word 2007 Document. 
Click Save.



The file is saved to the Desktop.



In the sidebar, clicking Red will display all files with the Red tag.



Clicking Blue will display all files with the Blue tag.



1.6 Gestures Review



Double click “my file 2”. This will launch TextEdit.



Click the Downloads folder in the Dock, click Desktop Pictures and click a picture. This will launch Preview.



Activate LaunchPad and click Safari.



At this point you have TextEdit, Preview and Safari running. Swipe up with 4 fingers.



All running applications appear on screen. Swipe down with 4 fingers.



Make Safari and Preview full screen by clicking the double arrows on the top right of their respective windows. Push up with 4 fingers again.



Note that Safari and Preview now have their own screen. Swipe left and right with 4 fingers to switch between applications. Switch to Desktop and swipe 
down with 4 fingers.



Swipe down with 4 fingers again. Note that all open and unopened TextEdit files are displayed.



1.7 Utilities



Pinch using your thumb and 3 fingers to activate LaunchPad. Search for Keychain.



Your keychain file (login.keychain) stores all your passwords. 



For instance, search for Classroom Wireless and double click it.



Click on Show password. Enter your login password and the password for the Classroom Wireless network will appear.



Pinch using your thumb and 3 fingers to activate LaunchPad. Search for Disk Utility and launch it. This is used to format disks. 



OS X Mavericks can back up everything in your hard disk by using Time Machine. All you need to do is plug in an external hard disk that has been 
formatted for the Mac.



1.8 Managing Files

  



1.8.1 Sorting and 
arranging documents/

files



Open a new Finder window. Click All My Files. You can see more stuff here now. Review all the items in the Finder toolbar and the sidebar.



Click the Downloads stack and drag the Desktop Pictures folder to the Desktop.



Open the Desktop Pictures folder and drag a few pictures to the Desktop. Close the Desktop Pictures folder. At this point your Desktop is looking pretty 
messy.



To clean it up, choose Show View Options in the View menu.



Choose Sort by: Kind.



Everything on the Desktop will be arranged by Kind on the right side of the screen.



1.8.2 Smart folders 
and advanced search



Smart Folders help you find stuff. click File -> New Smart Folder.



Click the + sign.



Modify the search so it reads Kind is Document. Click the + sign again.



Choose “Other…” from the Pop-up menu.



Select Tags in the search attribute window and click OK.



Modify the second statement to read Tags matches Blue. The document “my file word version” is the only document that appears as it is the only one that 
fulfils the search criteria.



Click Save.



Save this search as Blue Word Docs and Add to Sidebar.



Now every time you click on Blue Word Docs in the sidebar, any file that’s a document and tagged with Blue will appear.



Right click on my file 2 and choose Get Info… Add a Blue tag to my file 2 as well.



1.9. More File 
Operations



1.9.1 Review



Launch TextEdit, and create a new document as shown. 
Save As: my file 4 
Tags: Red, Blue 
Where: Desktop 
File Format: Word 2007 Document



Click the Smart Search we made earlier. Remember this will find all documents with the Blue tag.



The document we just made, “my file 4”, can be seen here.



Open My File 2 and Duplicate it. Save the duplicate as My File 6.



1.9.2 Locking 
documents



Click the arrow next to my file 6’s name and rename it my file 7. Save it to Documents.



Tick the Locked button.



Try to type something in the file. Since it is locked, this prompt will appear. Click Unlock to unlock the file.



1.9.3 Browsing 
versions



Drag and drop a picture into “my file 7”. Click Convert. Save the file by pressing Command-S.



Remove the picture by typing Command-Z (Undo).



Drag in another picture. Save the file by pressing Command-S.



Remove the second picture by typing Command-Z (Undo).



Drag in a third picture and save the file by pressing Command-S.



From the File menu, choose Revert To -> Browse All Versions.



All the previous versions of the “my file 7” are visible. Use the control strip on the right side of the screen to see them. Click the one you want and click 
Restore.



1.10 Other Applications 
to be Explored



1.10.1 Automator



Find Automator and launch it. Create a new file and drag in the following actions: 
Get Selected Finder Items 
Scale Images 
Rename Finder Items: Make Sequential



Save the file and duplicate it.



Save the duplicate with the parameters shown: 
Save As: renamersizer app 
Tags: blank 
Where: Desktop 
File Format: Application



The Automator app appears on the Desktop.



Click the Desktop Pictures folder and make a duplicate of it by right clicking it and choosing Duplicate.



Open the duplicated folder. Select all the items inside by pressing Command-A.



Drag the selected items to the Renamer App and watch what happens.



1.10.2 Dashboard and 
Widgets



Swipe to the right with 4 fingers. This is called the Dashboard. Here we can run mini applications called Widgets.



To add a widget to the screen, click the + button. More widgets can be found and downloaded from the Internet. Click More Widgets.



Safari launches and displays a list of widget categories.



Choose a widget and download it. It will be downloaded into the Downloads folder.



If you see this message, click OK.



The widget will be in the Downloads folder. Right click the widget and click Open.



Click Open.



Click Install.



The new widget has been added to the list of available widgets. Click on it.



The new widget is added to the Dashboard.



Click the - button to remove a widget from the Dashboard.



Click the - button in the More Widgets screen and click the x  and Delete to remove a widget from the Mac.



Clean up (optional)



Log in as Admin. Go to System Preferences. Click Users & Groups. Click your account. Click -.



Choose Delete the home folder and click Delete User. All your information has been removed.


